93 gsr looses power - Toronto Integras - Torontos Acura Integra Club

Integra Technical Questions and Tips Tech discussion for all things Acura Integra

93 gsr looses power

Reply

 
 
 
Old 03-30-2009, 05:28 PM
  #1  
n00b
Thread Starter
 
Join Date: Mar 2009
Location: Rexdale
Posts: 5
Default 93 gsr looses power

i have a b17 thats been driving me crazy. just wondering if anyone else had a similar problem.. after the car warms up i notice that when i accelerate above 3000 rpm it feels like it looses power till it hits vtec. sometimes when its lagging i let go of the gas and press it again and it will be fine. during the winter it never acted up. now that the temperature is getting warmer it does it more often... no engine lights come on. ive changed plugs, wires, fuel filter, air filter, changed the cat (thinking maybe it would be plugged...) this problem used to be alot worse last summer. i changed the distributor, but i got a used one. the problem got better but its still there. could it be i got another bad distributor?? any ideas? thanks.
BurninRT is offline  
Reply With Quote
Old 03-30-2009, 06:55 PM
  #2  
There's plenty to do outside my room but I choose not to!
iTrader: (2)
 
Buff4Prez Yo's Avatar
 
Join Date: Aug 2003
Location: The Hammer!
Posts: 8,166
Default

check the timing. is it throwing any CEL's?
Buff4Prez Yo is offline  
Reply With Quote
Old 03-30-2009, 08:33 PM
  #3  
n00b
Thread Starter
 
Join Date: Mar 2009
Location: Rexdale
Posts: 5
Default

no cel comes up... i thought maybe timing but it would do it all the time. mine only does it randomly.
BurninRT is offline  
Reply With Quote
Old 03-31-2009, 12:46 PM
  #4  
n00b
 
99jdmintegra86's Avatar
 
Join Date: Aug 2008
Location: rexdale
Posts: 37
Default

its garbage that why......LOL RT!!!!
99jdmintegra86 is offline  
Reply With Quote
Old 03-31-2009, 03:05 PM
  #5  
Member
 
3NE 2NR's Avatar
 
Join Date: Dec 2006
Location: Brown-Town
Posts: 959
Default

it might be the dizzy it self !
3NE 2NR is offline  
Reply With Quote
Old 04-15-2009, 09:51 PM
  #6  
n00b
 
freestyle's Avatar
 
Join Date: Mar 2007
Location: milton
Posts: 87
Default

check all ur ground points, make sure they're not corroded
freestyle is offline  
Reply With Quote
Old 04-15-2009, 10:50 PM
  #7  
n00b
Thread Starter
 
Join Date: Mar 2009
Location: Rexdale
Posts: 5
Default

I didnt check that but i will for sure..
BurninRT is offline  
Reply With Quote
Old 04-16-2009, 11:46 AM
  #8  
n00b
 
Join Date: Dec 2006
Location: Hamilton
Posts: 15
Default

sounds like ur dizzy, wires or spark plugs
Lonely Racer is offline  
Reply With Quote
Old 06-17-2009, 09:33 AM
  #9  
n00b
 
cre8tunes's Avatar
 
Join Date: Mar 2006
Location: maple
Posts: 18
Default

check the cataletic it happened to my brother and another friend of mine. In vtec it felt like the car wasnt moving.
cre8tunes is offline  
Reply With Quote
Old 06-25-2009, 07:02 PM
  #10  
n00b
 
Join Date: Feb 2007
Location: Ottawa
Posts: 6
Default

Could also be a MAP or TPS sensor problem. Any vacuum leaks?
b17gsr is offline  
Reply With Quote
Old 06-26-2009, 02:38 PM
  #11  
n00b
 
Join Date: May 2009
Location: Kingston
Posts: 7
Default

ive seen this a couple times, turned out to be distributor timing every time (maybe just luck?) when you replaced the dizzy did you use a timing gun? try advancing it just a tad and see if that helps as well.
nate is offline  
Reply With Quote
Old 06-28-2009, 03:17 AM
  #12  
n00b
 
Join Date: Aug 2008
Location: North York
Posts: 29
Default

My 94 did the samething once in a while.... right... cap and rotor use dialetric graese on the wire ends and make sure your coil wires are tight it worked for me
untouchable94 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
99jdmintegra86
Integra Parts Wanted
0
06-11-2012 12:34 AM
mayo
Integra Parts Wanted
1
10-20-2011 05:26 PM
g_man
Integra Parts For Sale
0
05-12-2009 10:11 AM
Nawaaz
Integra Technical Questions and Tips
10
05-07-2009 05:40 PM
NoToRiOuS_NinTegra
Integra Parts Wanted
2
01-22-2009 07:17 PM


Thread Tools
Search this Thread