b18c cold start up issues - Toronto Integras - Torontos Acura Integra Club

Integra Technical Questions and Tips Tech discussion for all things Acura Integra

b18c cold start up issues

Reply

 
 
 
Old 03-04-2010, 11:52 AM
  #1  
n00b
Thread Starter
 
Domani2K's Avatar
 
Join Date: Jun 2006
Location: Mississauga
Posts: 16
Default b18c cold start up issues

A month ago I swapped a b18c motor into my cx hatch. When the engine is warm, the motor absolutly RIPS and has no issues. On cold starts (car sitting for 2-3 hours) however, the motor seems to want to bog and stall. I have to hold it at 1500rpm to warm it up, because it wont do it on its own, like it should. After a minute or so of holding it at 1500rpm, i'll take my foot off the pedal, and it idles smoothly at 1000rpm. I hear that it could be a main relay problem, but I never had the problem before the swap, so what are the chances the relay would go at exactly the same time?.... unlikely I think...right? Do you guys think it may just be a slightly clogged injector acting up on cold starts? Any ideas from anyone would be greatly appreciated.
Domani2K is offline  
Reply With Quote
Old 03-04-2010, 06:43 PM
  #2  
There's plenty to do outside my room but I choose not to!
iTrader: (5)
 
Join Date: Apr 2009
Location: Burlington
Posts: 5,142
Default

Seems more like a fuel problem, not a relay problem.
Spike is offline  
Reply With Quote
Old 03-04-2010, 07:05 PM
  #3  
Member
 
irsdb7's Avatar
 
Join Date: May 2007
Location: Brampton
Posts: 622
Default

i used to have the same problem well still do but i went around it what year is your car? obd1 or obd2? if you have a obd1 check and clean your FITV located underneath your throttle body this thing controls cold temp idle

and while your at it also check and clean your IACV located behind your intake manifold

my car was obd2 converted to obd1 so i dont yet have a throttle body with the FITV so i had to get around this buy adjusting cold temp idle in the ECU via Hondata s300
irsdb7 is offline  
Reply With Quote
Old 03-04-2010, 10:11 PM
  #4  
Junior Member
iTrader: (2)
 
Join Date: Oct 2008
Location: Hamilton, ON
Posts: 265
Default

I had this problem when I completely blocked off my FITV.. Sounds like your ECU is overfueling because it's expecting the artificial vacuum leak the FITV creates on cold starts..
Burfy is offline  
Reply With Quote
Old 03-04-2010, 10:30 PM
  #5  
New Black 96 DC4

iTrader: (2)
 
Vida's Avatar
 
Join Date: Apr 2009
Location: Toronto
Posts: 3,024
Default

I may actually be getting this problem also. Ive noticed im using more gas than normal.
Vida is offline  
Reply With Quote
Old 03-04-2010, 11:16 PM
  #6  
Member
 
irsdb7's Avatar
 
Join Date: May 2007
Location: Brampton
Posts: 622
Default

Originally Posted by Burfy View Post
I had this problem when I completely blocked off my FITV.. Sounds like your ECU is overfueling because it's expecting the artificial vacuum leak the FITV creates on cold starts..
ooo yep i also had to trim fuel at start up or it would bog up like it was gonna die

needa get a obd1 TB bah

Originally Posted by Vida View Post
I may actually be getting this problem also. Ive noticed im using more gas than normal.
erm its not really that its a cold start up bogging issue.

for your burning more gas than usual it could be..
cus..
its winter..
bad o2
bad fuel filter
your ripping it
thats all i can think about for now
irsdb7 is offline  
Reply With Quote
Old 03-05-2010, 10:40 AM
  #7  
Who Are You?

iTrader: (8)
 
AcuratePaul's Avatar
 
Join Date: Mar 2009
Location: Wherever Your Not
Posts: 4,807
Default

I got same problem with my b18c. The rpms go up and down coming off the highway. And stays at around 1500 rpm when just sitting there. Got told it could be the manifold being clog or dirty but i'm putting an obd1 ecu into and getting it fuel mapped to fix it and make it run better then a tune and should be fine.
AcuratePaul is offline  
Reply With Quote
Old 03-05-2010, 11:18 PM
  #8  
Junior Member
iTrader: (2)
 
Join Date: Oct 2008
Location: Hamilton, ON
Posts: 265
Default

^ even when warm?
Burfy is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
irsdb7
Integra Technical Questions and Tips
6
12-08-2008 07:39 PM
g2tegg
Integra Technical Questions and Tips
1
08-28-2008 11:20 PM
DRT acura
Integra Technical Questions and Tips
6
11-18-2005 06:34 PM


Thread Tools
Search this Thread
Quick Reply: b18c cold start up issues


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.